`

1006

阅读更多
总时间限制:
3000ms
内存限制:
65536kB
描述
Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.
输入
You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.
输出
For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.
样例输入
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
样例输出
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
  
翻译:
 
描述:
一些人相信存在3种周期在人的生命中当人出生时,这三种周期分别是身体的,情感的,智力的,
它们每一周期的长度分别是23,28和33天,每个周期都有一个高峰值,在每个高峰的时候,每个人
都有最好的表现在相对的领域(身体的,情感的,智力的).举个列子,智力周期的高峰,
人会思维敏捷,精力容易高度集中。
因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,
我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,
到出现高峰的天数(不一定是第一次高峰出现的时间)。
你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)
下一次三个高峰落在同一天的时间(距给定时间的天数)。
例如:给定时间为10,下次出现三个高峰同天的时间是12,
则输出2(注意这里不是3)。
输入:
输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间
(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。
所有给定时间是非负的并且小于365, 所求的时间小于21252 。
输出
从给定时间起,
下一次三个高峰同天的时间(距离给定时间的天数)。
输出:
从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。
 
解决方案一:G++
 
#include<iostream>
#include<cstdio>
using namespace std ;
int main(){
  int p,e,i,d,n=1;
  cin>>p>>e>>i>>d  ;
 while(p!=-1 && e!=-1 && i!=-1 && d!=-1 )
 {  int l;
     for(l=d+1;l<=21252;l++) if((l-p)%23==0) break ;
     for(;l<=21252 ;l=l+23) if((l-e)%28==0) break ;
     for(;l<=21252;l=l+23*28) if((l-i)%33==0)  break ;
    printf("Case %d: the next triple peak occurs in %d days.\n",n,l-d);
       n++ ;
    cin>>p>>e>>i>>d  ;
 }
   return 0 ;
}
 
 
 
 
解决方案二:   Java
 
import java.util.Scanner;

public class Main {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in) ;
		int p,e,i,d,n=1 ;
		p = sc.nextInt() ;
		e = sc.nextInt() ;
		i = sc.nextInt() ;
		d = sc.nextInt() ;
		while(p!=-1 && e!=-1 && i!=-1 && d!=-1 )
		{
			
			int l;
		     for(l=d+1;l<=21252;l++) if((l-p)%23==0) break ;
		     for(;l<=21252 ;l=l+23) if((l-e)%28==0) break ;
		     for(;l<=21252;l=l+23*28) if((l-i)%33==0)  break ;
		System.out.printf("Case %d: the next triple peak occurs in %d days.\n",n,l-d);
            n++ ;
            p = sc.nextInt() ;
    		e = sc.nextInt() ;
    		i = sc.nextInt() ;
    		d = sc.nextInt() ;
		}

	}

}
 
解题思路:
 
 令所求的时间为当年的第x天,则x具有如下性质:
1) 21252 >= x > d
2) (x-p)%23=0
3) (x-e)%28=0
4) (x-i)%33=0
 
 
 // 读入p, e, i, d
//  j从d+1 循环到21252, 如果 (j-p)%23==0,跳出循环
//  j从上次跳出循环的值循环到21252,
        如果 (j-e)%28==0,跳出循环
//  j从上次跳出循环的值循环到21252,
        如果 (j-i)%33==0,跳出循环
//  输出j-d
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics