`
20386053
  • 浏览: 433225 次
文章分类
社区版块
存档分类
最新评论

FZU 2150 Fire Game

 
阅读更多

两个点对着BFS。。。。

Problem 2150 Fire Game

Accept: 21Submit: 45
Time Limit: 1000 mSecMemory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>

using namespace std;

const int INF=0x3f3f3f3f;

int dir_x[4]={1,-1,0,0};
int dir_y[4]={0,0,1,-1};


struct node
{
    int x,y,t;
};

char map[15][15];
int vis[15][15],n,m,tot,ans,run;
bool flag=false;
queue<node> q[2];
node NA[120];

bool inside(node a)
{
    if(a.x>=0&&a.x<n&&a.y>=0&&a.y<m) return true;
    return false;
}

void bfs(int k,int sum)
{
    if(sum==tot) flag=true;
    node u,v;int sin=0;
    int f=0;
    while(!q[k].empty())
    {
        v=q[k].front();q[k].pop();
        for(int i=0;i<4;i++)
        {
            u=v;u.x+=dir_x[i];u.y+=dir_y[i]; u.t+=1;
            if(inside(u)&&map[u.x][u.y]=='#'&&vis[u.x][u.y]==0)
            {
                vis[u.x][u.y]=1; sin++;
                run=max(run,u.t);
                q[!k].push(u);
            }
        }
    }
    if(sum+sin==tot) flag=true;
    if(!q[!k].empty())
        bfs(!k,sum+sin);
}

int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        memset(NA,0,sizeof(NA));
        memset(vis,0,sizeof(vis));
        ans=INF;tot=0;run=0;
        while(!q[0].empty()) q[0].pop();
        while(!q[1].empty()) q[1].pop();
        for(int i=0;i<n;i++) scanf("%s",map[i]);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(map[i][j]=='#')
                {
                    NA[tot++]=(node){i,j,0};
                }
            }
        }
        if(tot<=2) ans=0;
        else
        {
            for(int i=0;i<tot;i++)
            {
                for(int j=i+1;j<tot;j++)
                {
                    q[0].push(NA[i]); q[1].push(NA[j]);
                    memset(vis,0,sizeof(vis));
                    run=0;flag=false;
                    vis[NA[i].x][NA[i].y]=vis[NA[j].x][NA[j].y]=1;
                    bfs(0,2);
                    if(flag&&ans>run) ans=run;
                }
            }
        }
        if(ans==INF) ans=-1;
        printf("Case %d: %d\n",cas++,ans);
    }
    return 0;
}






分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics