`
hellojyj
  • 浏览: 59104 次
  • 性别: Icon_minigender_1
  • 来自: 长沙
社区版块
存档分类
最新评论

HDU 1009 FatMouse' Trade

    博客分类:
  • ACM
阅读更多

原题传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1009

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42086    Accepted Submission(s): 14004


Problem Description

 

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input

 

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

 

Output

 

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
 

 

Author

 

CHEN, Yue
 

 

Source

 

 

 

 

Recommend

 

JGShining   |   We have carefully selected several similar problems for you:  1008 1050 1005 1051 1004
分析:这是一个简单的贪心算法,部分背包问题,用结构体数组,以J/F比值升序排序即可。然后遍历数组的时候判断每个房间能不能全拿,如果能就left-F,total+=J,不能就按照比例来取,在不能的时候Mouse用尽M的时候,这时候break就ok了,注意百分比计算的时候的强制转换。
 
//部分背包问题 贪心算法 HDU1009

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN = 1100;
struct Value{
    int J;
    int F;
    double j_f;
};
bool cmp(Value a,Value b){
    return a.j_f>b.j_f;
}
int N,M,j,f,leftM;
double total;
Value p[MAXN];
int main(){
   while(scanf("%d%d",&M,&N) ==2){
        if(M == -1&&N ==-1)break;
        leftM = M;
        total = 0;
         for(int i=0;i<N;i++){
            scanf("%d%d",&j,&f);
            p[i].J = j;
            p[i].F = f;
            p[i].j_f = ((double)j)/f;
         }
         sort(p,p+N,cmp);
         for(int i=0;i<N;i++){
            if(p[i].F<=leftM){
                leftM = leftM - p[i].F;
                total += p[i].J;
            }else{
                total += (((double)leftM)/p[i].F * p[i].J);
                break;
            }
         }
         printf("%.3f\n",total);
    }
    return 0;
}
 
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics