`

翻到了做过的第一道ACM题目

J# 
阅读更多

Financial Management


DescriptionLarry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input


The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output


The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42
Answer:
import java.text.DecimalFormat;
import java.util.*;
public class acm {
public static void main(String args[]) throws Exception {
float[] a = new float[12];
float j = 0;
for (int i = 0; i < 12; i++) {
Scanner cin = new Scanner(System.in);//这句放到循环外,否则runtime error;
a[i] = cin.nextFloat();
j = a[i] + j;
}
j = j / 12;
DecimalFormat formatter = new DecimalFormat("#.00");
Currency currency = Currency.getInstance(Locale.US);
String symbol = currency.getSymbol(Locale.US);
String r = formatter.format(j);
System.out.print(symbol + r);
}
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics