`
zqynux
  • 浏览: 35673 次
  • 性别: Icon_minigender_1
  • 来自: 湖南
社区版块
存档分类
最新评论

USACO 2.3 Money Systems 货币系统

阅读更多
Money Systems

The cows have not only created their own government but they have chosen to create their own money system. In their own rebellious way, they are curious about values of coinage. Traditionally, coins come in values like 1, 5, 10, 20 or 25, 50, and 100 units, sometimes with a 2 unit coin thrown in for good measure.

The cows want to know how many different ways it is possible to dispense a certain amount of money using various coin systems. For instance, using a system of {1, 2, 5, 10, ...} it is possible to create 18 units several different ways, including: 18x1, 9x2, 8x2+2x1, 3x5+2+1, and many others.

Write a program to compute how many ways to construct a given amount of money using supplied coinage. It is guaranteed that the total will fit into both a signed long long (C/C++) and Int64 (Free Pascal).

PROGRAM NAME: money
INPUT FORMAT
The number of coins in the system is V (1 <= V <= 25).

The amount money to construct is N (1 <= N <= 10,000). Line 1:  Two integers, V and N 
Lines 2..:  V integers that represent the available coins (no particular number of integers per line)


SAMPLE INPUT (file money.in)
3 10
1 2 5

OUTPUT FORMAT
A single line containing the total number of ways to construct N money units using V coins.
SAMPLE OUTPUT (file money.out)
10


描述
母牛们不但创建了他们自己的政府而且选择了建立了自己的货币系统。由于他们特殊的思考方式,他们对货币的数值感到好奇。

传统地,一个货币系统是由1,5,10,20 或 25,50, 和 100的单位面值组成的。

母牛想知道有多少种不同的方法来用货币系统中的货币来构造一个确定的数值。

举例来说, 使用一个货币系统 {1,2,5,10,...}产生 18单位面值的一些可能的方法是:18x1, 9x2, 8x2+2x1, 3x5+2+1,等等其它。写一个程序来计算有多少种方法用给定的货币系统来构造一定数量的面值。保证总数将会适合long long (C/C++) 和 Int64 (Free Pascal),即在0 到2^63-1之间。

格式
PROGRAM NAME: money

INPUT FORMAT:

(file money.in)

货币系统中货币的种类数目是 V (1<= V<=25)。要构造的数量钱是 N (1<= N<=10,000)。

第 1 行: 二整数,V 和 N 。

第 2 行: 可用的货币的面值 。

OUTPUT FORMAT:

(file money.out)

单独的一行包含那个可能的用这v种硬币凑足n单位货币的方案数。

SAMPLE INPUT
3 10
1 2 5
SAMPLE OUTPUT
10

======================= 华丽的分割线 =======================
  看到这题就知道又是最复杂, 最有用的DP问题..(天啊~!DP我怎么还没开窍`?)
  dp方程:
  f[j] 代表构造价值为j的方法有多少种`?
  f[j] += f[j - c[i]]
  DP我真的不会解释,, 下次把背包九讲仔细看下~!!!
  先把代码上上吧~
/*
LANG: C
ID: zqy11001
PROG: money
*/
#include <stdio.h>
#define getint(i) scanf("%d", &i)

long long f[10001];

int main(void)
{
	int n, m;
	int i, j, k, t;
	freopen("money.in", "r", stdin);
	freopen("money.out", "w", stdout);
	getint(n);
	getint(m);
	f[0] = 1;
	for(i = 1; i <= n; i++){
		getint(t);
		for(j = t; j <= m; j++){
			f[j] += f[j - t];
		}
	}
	printf("%lld\n", f[m]);
	return 0;
}
0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics