`
844604778
  • 浏览: 573504 次
文章分类
社区版块
存档分类
最新评论

题目1001:A + B for Matrices(九度 Online Judge)

 
阅读更多

题目1001:A+B for Matrices(九度 Online Judge)

1,真题


题目1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:9896

解决:4030

题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题

2,分析

题目大致意思可以翻译为如下:
让矩阵A 和矩阵B相加,判断相加后的矩阵C中,行和列数字全为0的个数。再说得明白点,就是用户先输入要计算的两矩阵行列大小,因为相加,两矩阵行列大小肯定一样。然后依次输入矩阵A和矩阵B的值。输入完成后,自动相加,假设相加结果为矩阵C。先逐行循环统计矩阵C中,是否有一行全为0,若有,则统计数count加1,再逐列循环统计矩阵C中,是否有一行全为0,若有,则统计数count加1,最后输出count的值。

3,答案

import java.util.Scanner;
/**
 * to test problem_1001
 * @author Sunkun
 * Date: 2013.09.24
 */
public class problem_1001{
	public static void main(String[] args) {
		
		int row = 0;
		int colum = 0;
		Scanner input = new Scanner(System.in);
		
		// 输入矩阵的行列大小
		while(input.hasNext()){
			
			int m = input.nextInt();
			if(m <= 0){
				break;
			}else{
				row = m;
			}			
			if(input.hasNext()){
				colum = input.nextInt();
			}
			
			// 给A + B中的A赋值
			int[][] a;
			a = new int[row][colum];		
			for(int i = 0; i < row; i++){
				for(int j = 0; j < colum; j++){
					if(input.hasNext()){
						a[i][j] = input.nextInt();	
					}
				}
			}
			
			// 给A + B中的B赋值
			int[][] b;
			b = new int[row][colum];
			for(int i = 0; i < row; i++){
				for(int j = 0; j < colum; j++){
					if(input.hasNext()){
						b[i][j] = input.nextInt();
					}
				}
			}
			
			// 计算 A + B,得到矩阵C,
			int[][] sum;
			sum = new int[row][colum];
			for(int i = 0; i < row; i++){
				for(int j = 0; j < colum; j++){
					sum[i][j] = a[i][j] + b[i][j];
				}
			}
			
			int count = 0;
			int i = 0,j = 0;
			
			// 统计一行元素是否全为0,若是,则count加1
			for(i = 0; i < row; i++){
				for(j = 0; j < colum; j++){
					if(sum[i][j] != 0){
						break;
					}
				}
				if(j == colum){
					count++;
				}
			}
			
			// 统计一列元素是否全为0,若是,则count加1
			for(i = 0; i < colum; i++){
				for(j = 0; j < row; j++){
					if(sum[j][i] != 0){
						break;
					}
				}
				if(j == row){
					count++;
				}
			}
			
			// 输出结果
			System.out.println(count);
		}
	}
}

4,备注

上述代码直接复制是AC不了的,把类名problem_1001改为Main就可以直接上传通过了:)



分享到:
评论

相关推荐

    题目1001:A+B for Matrices

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

    Local Molecular Structure of (MnO6)10- coordination complex for Mn2+ ions in A{[(CH3)2N]2OPOPO[N(CH3)2]2}(ClO4)2:Mn2+ (A=Mg, Zn): a Complete Energy Matrices Study

    A{[(CH3)2N]2OPOPO[N(CH3)2]2}(ClO4)2:Mn2+ (A=Mg, Zn) 体系中 (MnO6)10- 配位复合物的局域分子结构:完全能量矩阵研究,卢成,邝小渝,本文介绍了一个简单的研究(MnO6)10- 配位复合物的局域分子结构的理论方法。...

    如何:编写 parallel_for 循环.doc

    编写 parallel_for 循环 Parallel_for 循环是并发编程中的一个重要概念,用于并行执行循环体中的任务以提高程序的执行效率。在本文中,我们将详细介绍如何编写 parallel_for 循环,並讨论其在矩阵乘法操作中的应用...

    Toeplitz and Circulant Matrices: A review

    ### 托普利茨(Toeplitz)与循环矩阵(Circulant Matrices):综述 #### 引言 本文旨在对托普利茨矩阵和循环矩阵进行深入浅出的介绍,着重于它们的基本性质及其在信号处理、随机过程等领域的应用。尽管文中包含了...

    Matrix-Datatype:C ++中的Matrix数据类型

    矩阵数据类型和计算器这是一个简单的类定义,它从C ++标准库的向量数据类型派生矩阵数据类型。 我计划随着时间的流逝增加更多功能,并制作出真正的矩阵计算器。当前支持的操作矩阵加/减标量乘法矩阵乘法转置创建身份...

    终于成功使用asdoc生成了文档

    在IT行业中,生成文档是软件开发过程中的一个重要环节,它能帮助开发者理解代码结构和功能,提高团队协作效率。本文将详细介绍如何使用`asdoc`工具生成文档,以及与之相关的知识点。 `asdoc`是Adobe Flex SDK中的一...

    Direct methods for sparse matrices

    ### Direct Methods for Sparse Matrices #### 一、概述 《Direct Methods for Sparse Matrices》(稀疏矩阵的直接方法)是牛津大学出版社于2017年出版的第二版书籍,该书属于数学领域,重点介绍了处理稀疏矩阵的...

    Handbook of Matrices

    - **矩阵乘法**:两个矩阵A和B相乘(\( A \times B \)),结果为一个新的矩阵C,其中C的每个元素\( c_{ij} \)是A的第i行与B的第j列的对应元素乘积之和。 #### 1.3 矩阵之间的不等式关系 - **矩阵范数**:用于衡量...

    经典随机矩阵理论入门书:Random Matrices (Mehta,

    This book gives a coherent and detailed description of analytical methods devised to study random matrices. These methods are critical to the understanding of various fields in in mathematics and ...

    ENHANCING SIMILARITY MATRICES FOR MUSIC AUDIO ANALYSIS

    structural properties of similarity matrices based on two concepts: first, we introduce a new class of robust and scalable audio features which absorb local temporal variations. As a second ...

    矩阵乘法(Multiplying Matrices)

    要进行矩阵乘法,A和B必须满足一个关键条件:A的列数n必须等于B的行数n。在这种情况下,我们可以得到一个新的矩阵C(m×k),其每个元素是对应位置上A和B元素乘积的和。 矩阵乘法的具体步骤如下: 1. 初始化结果...

    A well-conditioned estimator for large-dimensional covariance matrices.pdf

    在统计学和数据分析中,估计高维协方差矩阵是许多关键问题的核心,尤其是在金融、机器学习和信号处理等领域。本文“一个适用于大维数协方差矩阵的良好条件估计器”探讨了在处理大规模数据集时,如何有效地估计并逆...

    A SURVEY OF CONDITION NUMBER ESTIMATION FOR TRIANGULAR MATRICES

    例如,在线性方程组 \( Ax = b \) 中,若矩阵 \( A \) 的条件数较大,则解 \( x \) 对数据扰动非常敏感。 - **误差估计**:条件数可以用来估计解的相对误差相对于输入数据误差的比例。例如,在给定的数据扰动 \( E \...

    SDL使用示例和一个YUV文件

    SDL使用示例和一个YUV文件

    Graphs and Matrices.pdf

    outline the basic properties of some matrices associated with a graph. This is followed by topics in graph theory such as regular graphs and algebraic connectivity. Distance matrix of a tree and its ...

    Moment Matrices and Optimization

    ### Moment Matrices与优化 #### 一、引言 在数学和工程领域中,多项式优化问题是一个重要的研究方向,特别是在解决复杂系统的设计与分析时。这类问题涉及到最小化一个多项式函数,同时满足一系列由其他多项式表示...

    Deblurring Images: Matrices, Spectra, and Filtering

    Deblurring Images: Matrices, Spectra, and Filtering (Fundamentals of Algorithms 3) (Fundamentals of Algorithms) By Per Christian Hansen Publisher: Society for Industrial and Applied Mathematic ...

Magicbox
Global site tag (gtag.js) - Google Analytics