`
从此醉
  • 浏览: 1045643 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

使用hash表加速寻找-POJ 3349

 
阅读更多

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integern, 0 <n≤ 100000, the number of snowflakes to follow. This will be followed bynlines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.


题目大意:每片雪花有 6 个角长度的值,对于不同的雪花而言,这些值可能被反转,并且开头的长度未必是一致的

例如 1 2 3 4 5 6和 4 3 2 1 6 5,虽然他们表面上不同,但是经过反转和偏移以后,就是相同的雪花。

在输入数据中如果有相同的雪花,则输出yes,否则输出no。


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int HN = 9999; //HASH表的大小
int n;
struct Node {
	int index;
	Node * next;
};
int snow[100002][6]; //存储数据
Node nodes[100002]; //链表
Node hashtable[HN]; //hash表,存储链表头

//比较s1 和 s2 是否相同
bool check(int s1, int s2) {
	bool flag;
	int temp;
	for (int j = 0; j < 6; j++) {
		flag = true;
		for (int step = 0; step < 6; step++) {
			if (snow[s1][(j + step) % 6] != snow[s2][step]) {
				flag = false;
				break;
			}
		}
		if (flag)
			return true;
	}
	for (int j = 0; j < 6; j++) {
		flag = true;
		for (int step = 0; step < 6; step++) {
			temp = j - step;
			if (temp < 0)
				temp += 6;
			if (snow[s1][temp] != snow[s2][step]) {
				flag = false;
				break;
			}
		}
		if (flag)
			return true;
	}
	return false;
}

int sum;
bool solve() {
	for (int i = 1; i <= n; i++) {
		sum = 0;
		for (int j = 0; j < 6; j++) {
			scanf("%d", &snow[i][j]);
			sum += snow[i][j];
		}
		int t = sum % HN;
		//采用头部插入法
		nodes[i].index = i;
		nodes[i].next = hashtable[t].next;
		hashtable[t].next = &nodes[i];
	}

	//在hash表中比较每个链表,一个链表即有冲突的节点集合
	for (int i = 0; i < HN; i++) {
		for (Node * n1 = hashtable[i].next;  n1 != NULL  ; n1 = n1->next)
			for (Node * n2 = n1->next; n2 != NULL ; n2 = n2->next)
				if (check(n1->index, n2->index))
					return true;
	}
	return false;
}

int main() {
	freopen("in.txt","r", stdin);
	cin >> n;
	memset(hashtable, 0, sizeof(hashtable));
	memset(nodes, 0, sizeof(nodes));
	if(solve())
		printf("Twin snowflakes found.\n");
	else
		printf("No two snowflakes are alike.\n");
	return 0;
}







分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics