`
从此醉
  • 浏览: 1045606 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

贪心算法-Doing Homework again

 
阅读更多

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4294Accepted Submission(s): 2505


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output
For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4

Sample Output
0 3 5




#include <stdio.h>
#include <stdlib.h>
int t, n, i, j, k;
typedef struct Node {
	int time, val;

}Node;
int cmp(const void * a, const void * b){
	Node * aa = (Node *)a;
	Node * bb = (Node *)b;
	if(bb->val - aa->val == 0)
		return aa->time - bb->time;
	return bb->val - aa->val;

}
struct Node nodes[1001];
int opt[1001];
int main(void) {

	
	scanf("%d", &t);

	while (t--) {
		int max = 0,sum=0;
		scanf("%d", &n);
		for (i = 0; i < n; i++){
			scanf("%d", &nodes[i].time);
			if(max < nodes[i].time)
							max = nodes[i].time;

		};

		for (i = 0; i < n; i++){
			scanf("%d", &nodes[i].val);
			sum += nodes[i].val;

		}

		for(i=0; i<=max; i++)
			opt[i] = 0;
		qsort(nodes, n, sizeof(Node) ,cmp); //按学分排序

		int ans =0;
		for(i=0; i<n; i++){ //优先大学分。同时,大学分的能往后拖延则拖延
			int k = nodes[i].time;
			while(opt[k] && k>0){
				k--;
			}
			if(k != 0){ //表明该课程可以完成
				opt[k] = nodes[i].val;
				ans += opt[k];
			}

		}

		printf("%d\n",sum-ans);

	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics