`

PAT 1002. A+B for Polynomials (25)

    博客分类:
  • PAT
 
阅读更多

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

 

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include<stdio.h>
#include<string.h>
double polyRs[1001];
int main(){
  int k, nk,maxIndex;
  double ank;
  int count = 0;
  int i;
  memset(polyRs,0,sizeof(int));
  scanf("%d", &k);
  maxIndex=0;
  while(k--){
      scanf("%d%lf",&nk, &ank);
      polyRs[nk] += ank;
      if(nk>maxIndex) maxIndex = nk;
  }
  scanf("%d", &k);
  while(k--){
      scanf("%d%lf",&nk, &ank);
      polyRs[nk] += ank;
      if(nk>maxIndex) maxIndex = nk;
  }
  for (i=maxIndex;i>=0;i--)
      if (polyRs[i] != 0 ) count++;
  printf("%d", count);
  for(i = maxIndex; i >=0; i--){
      if(polyRs[i] !=0){
          printf(" %d %.1lf", i, polyRs[i]);
      }
  }
  return 0;
} 

 

notes:

float---scanf("%f");

double -- scanf("%lf");

初始化数组#include<string.h> memset(polyRs,0,sizeof(int));

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics