`

hdu 1258 Sum It Up

    博客分类:
  • dfs
阅读更多

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1099    Accepted Submission(s): 528

Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

 

Sample Input
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
Sample Output
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
 
      继续dfs。这题有一点要注意,因为每一个结果不能有相同,所以,每一次搜完之后,要判断下一个搜的数是否与之前的数相等,若相等则不用搜,因为在之前已经又大到小排序了。
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <algorithm>
using namespace std;

int t, len, sum, pos;
int a[15], b[15];

bool cmp(int a, int b)
{
    return a > b;
}

void dfs(int x, int rank, int temp, int pos)
{
    int i;
    if(temp > sum) return;
    if(temp == sum)     //若全部找到,则输出
    {
        t++;
        printf("%d", b[0]);
        for(i = 1; i < pos; i++)
        {
            printf("+%d", b[i]);
        }
        printf("\n");
    }

    for(i = rank; i < len; i++)
    {
        b[pos] = a[i];
        dfs(a[i], i+1, temp+a[i], pos+1);
        //关键:搜索完毕后,若下一个搜索的数仍与当前相同,则跳过直至不相同
        while(i+1<len && a[i]==a[i+1])
        {
            i++;
        }
    }

}

int main()
{
    int i;
    while(scanf("%d %d", &sum, &len) != EOF)
    {
        if(len == 0) break;
        printf("Sums of %d:\n", sum);
        for(i = 0; i < len; i++)
        {
            scanf("%d", &a[i]);
        }
        sort(a, a+len, cmp);
        t = 0;
        dfs(0, 0, 0, 0);    //开始深搜dfs

        if(t == 0) printf("NONE\n");
    }

    return 0;
}
 
3
16
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics