`

POJ 1679 The Unique MST (Kruskal判断最小生成树是否唯一)

 
阅读更多
The Unique MST
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17062   Accepted: 5920

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

 
题意:给一个图,问其最小生成树是否惟一。

思路:用Kruskal 算出最小生成树的值,并记录每一条边,然后枚举去掉这些边 看其是否也能构成最小生成树且值相同。注意 在删边后,可能图构不成一棵树,得判断一下
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int VM=120;
const int EM=10010;

struct Edge{
    int u,v,cap;
}edge[EM<<1];

int n,m,flag;
int ans,father[VM];

void makeSet(){
    for(int i=1;i<=n;i++)
        father[i]=i;
}

int findSet(int x){
    if(x!=father[x]){
        father[x]=findSet(father[x]);
    }
    return father[x];
}

int cmp(Edge a,Edge b){
    return a.cap<b.cap;
}

void Kruskal(){
    makeSet();
    sort(edge,edge+m,cmp);
    int path[EM],cnt=0;
    ans=0;
    for(int i=0;i<m;i++){
        int u=findSet(edge[i].u);
        int v=findSet(edge[i].v);
        if(u!=v){
            father[v]=u;
            path[cnt++]=i;      //记录路径
            ans+=edge[i].cap;
        }
    }
    for(int k=0;k<cnt;k++){     //枚举去掉每一条边
        makeSet();
        int sum=0,j=0;
        for(int i=0;i<m;i++){
            if(i==path[k])
                continue;
            int u=findSet(edge[i].u);
            int v=findSet(edge[i].v);
            if(u!=v){
                father[v]=u;
                sum+=edge[i].cap;
                j++;
            }
        }
        if(j==n-1 && sum==ans){     //判断是否能构成树 且 是否与最小生成树相等
            flag=0;
            return ;
        }
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].cap);
        flag=1;
        Kruskal();
        if(flag)
            printf("%d\n",ans);
        else
            printf("Not Unique!\n");
    }
    return 0;
}
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics