`
linest
  • 浏览: 150249 次
  • 性别: Icon_minigender_1
  • 来自: 内蒙古
社区版块
存档分类
最新评论

ZOJ-3311 字符串

    博客分类:
  • acm
 
阅读更多
3311:满足下列情况的字符串AC,否则WA
1. there are only three distinct capital letters of the strings: Z, O, and J;
2. any string that is in the form xZOJxO is acceptable, where x is a string either empty or composed of O's only;
3. if aZbJc is acceptable, then aZbOJcO is acceptable, where a, b and c are all strings either empty or composed of O's only

Sample Input

ZOJO
OZOJOO
OZOOJOOO
OZOZOJOO
OOZOOJO

Sample Output

Accepted
Accepted
Accepted
Wrong Answer
Wrong Answer

思路:字符串拆分,统计前中后三部分个数。
注意Z和J的个数判断以及顺序判断。
一开始没判断顺序WA了好久。%>_<%

#include<iostream>
using namespace std;
#include<string.h>
#include<string>

string str;
int main()
{
	bool isAC;
	string left;
	string top;
	string mid;
	string end;

	while(cin>>str)
	{
		isAC = true;
		if(str.find("Z")!=string::npos)
		{
			left = str.substr(str.find("Z")+1,str.length());
			if(left.find("Z")!=string::npos)
				isAC = false;
		}
		else
			isAC=false;

		if(str.find("J")!=string::npos)
		{
			left = str.substr(str.find("J")+1,str.length());
			if(left.find("J")!=string::npos)
				isAC = false;
		}
		else
			isAC=false;

		//J come before Z
		if(str.find("J")<str.find("Z"))
			isAC=false;

		if(isAC)
		{
			top = str.substr(0,str.find("Z"));
			mid = str.substr(str.find("Z")+1,str.find("J")-str.find("Z")-1);
			end = str.substr(str.find("J")+1,str.length());
			if(!(end.length()-top.length()==mid.length()&&mid.length()>=1))
				isAC = false;
		}

	
		if(isAC)
			cout<<"Accepted"<<endl;
		else
			cout<<"Wrong Answer"<<endl;
	}

}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics