`
richard_ma
  • 浏览: 15158 次
最近访客 更多访客>>
社区版块
存档分类
最新评论

hdu1021 推理规律

阅读更多
Fibonacci Again

http://acm.hdu.edu.cn/showproblem.php?pid=1021

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

解题思路
同余四则运算
(a mod m) + (b mod m) 和 (a + b) mod m 是同余的。
由于没有同余符号,所以这样也可以表示:
((a mod m) + (b mod m)) mod m = (a + b) mod m

观察前两项,mod 3的余数分别是1和2,则项数和余数的对应关系为:
index  mod
0      1
1      2
2      0      1 + 2 = 3...0
3      2      2 + 0 = 2
4      2      0 + 2 = 2
5      1      2 + 2 = 4...1
6      0      2 + 1 = 3...0
7      1      1 + 0 = 1
8      1      0 + 1 = 1
9      2      1 + 1 = 2
10     0      1 + 2 = 3...0
11     2      2 + 0 = 2
12     2      0 + 2 = 2
13     1      2 + 2 = 4...1
14     0      2 + 1 = 3...0

很明显,从第二个开始,每4个一循环。
公式:index mod 4 = 2

#include <stdio.h>
#include <stdlib.h>

int main (int argc, char const* argv[])
{
    int n;

    while (scanf("%d", &n) != EOF) {
        if (n % 4 == 2) {
            printf("yes\n");
        } else {
            printf("no\n");
        }
    }

    return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics