`
Simone_chou
  • 浏览: 184819 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Known Notation(分析模拟)

    博客分类:
  • ZOJ
 
阅读更多
Known Notation
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

 

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

 

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

 

1
0
2

 

       题意:

       给出 T 组样例,每个样例都有一串数字 + * 的字符串。问最少需要多少个操作使其变为逆波兰式,可以增加字符进去,也可以任意交换两个字符的位置。

 

       思路:

       当 num < star + 1 的时候才需要添加数字进去,设添加的数字数为 k ,之后统计的时候,num 数初始值设为 k,star 数初始值设为 0,再从头开始扫一遍,若遇到当前 num < star + 1,说明需要交换操作。最后输出 k + 交换次数 即为答案。

 

     AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

char str[1005];

int main() {

    int t;
    scanf("%d", &t);

    while (t--) {
        scanf("%s", str);

        int len = strlen(str);

        int num = 0, star = 0;
        for (int i = 0; i < len; ++i) {
            if (str[i] == '*') ++star;
            else ++num;
        }

        int k = star + 1 - num;
        if (k < 0) k = 0;

        int sum = k;
        num = k;
        star = 0;

        for (int i = 0; i < len; ++i) {
            if (str[i] == '*') ++star;
            else ++num;

            if (star + 1 > num) {
                ++sum;
                ++num;
                --star;
            }
        }

        printf("%d\n", sum);
    }

    return 0;
}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics