`
yidongkaifa
  • 浏览: 4061541 次
文章分类
社区版块
存档分类
最新评论

[Windows+Phone+7]+c#编码规范

 
阅读更多

Windows Phone 7的项目开始了,但公司没有相关的Coding Standards, 因此在国外网站上找了一份感觉比较靠谱的,以后就用这个了。翻译就没有必要了吧,程序员英文不好是很悲剧的,看不懂的好好学学英语吧,至少也要有cet6的阅读水平吧,不然学东西就累了。


原文 http://www.codeproject.com/KB/cs/c__coding_standards.aspx

Introduction

Believe it: majority of the programmers write "working code," but not "efficient code." As we mentioned in the beginning of this tutorial, do you want to become the "Most Valued Professional" of your company? Writing "efficient code" is an art that you must learn and practice.

Naming Conventions andStandards

  • Pascal casing: the first character of all words is upper case and the other characters are lower case.
  • Camel casing: the first character of all words, except the first word, is upper case and other characters are lower case.

Use Pascal casing for class names:

public class HelloWorld
{
  ...
}

Use Pascal casing for method names:

public class HelloWorld
{
  void SayHello(string name)
  {
    ...
  }
}

Use Camel casing for variables and method parameters:

public class HelloWorld
{
 int totalCount = 0;
 void SayHello(string name)
 {
  string fullMessage = "Hello " + name;
  ...
 }
}

Do not use Hungarian notation to name variables. In earlier days, most programmers liked it: having the data type as a prefix for the variable name and usingm_as the prefix for member variables, e.g:

string m_sName;
int nAge;

However, in .NETcodingstandards, this is not recommended. Usage of data type andM_to represent member variables should not be done. All variables should use Camel casing. Use meaningful, descriptive words to name variables:

  • Do not use abbreviations. Usename,address,salaryetc. instead ofnam,addr,sal.
  • Do not use single character variable names likei,n,x, etc. Use names likeindexandtemp.

One exception in this case would be variables used for iterations in loops:

for ( int i = 0; i < count; i++ )
{
 ...
}

If the variable is used only as a counter for iteration and is not used anywhere else in the loop, many people still like to use a single char variable (i) instead of inventing a different suitable name.

  • Do not use underscores (_) in variable names.
  • Namespace names should follow the standard pattern.
<company name>.<product name>.<top level module>.<bottom level module>

File name should match with class name. For example, for the classHelloWorld, the file name should behelloworld.cs(orhelloworld.vb).

Indentation and spacing: use TAB for indentation. Do not use spaces.

Comments should be in the same level as the code. Curly braces ( {} ) should be in the same level as the code outside the braces. Use one blank line to separate logical groups of code.

bool SayHello (string name)
{
  string fullMessage = "Hello " + name;
  DateTime currentTime = DateTime.Now;
  string message = fullMessage + ", the time is : " + 
                  currentTime.ToShortTimeString();
  MessageBox.Show ( message );
  if ( ... )
  {
  // Do something

  // ...

  return false;
  }
  return true;
}

This code looks better than the code shown above:

bool SayHello ( string name )
{
  string fullMessage = "Hello " + name;
  DateTime currentTime = DateTime.Now;
    string message = fullMessage + ", the time is : " + 
    currentTime.ToShortTimeString();
  MessageBox.Show ( message );
  if ( ... )
  {
    // Do something

    // ...

   return false;
 }

  return true;
}

There should be one and only one single blank line between each method inside the class. The curly braces should be on a separate line and not in the same line asif,for, etc.

Good:

  if ( ... ) 
  {
   // Do something

  }

Not good:

  if ( ... ) {
   // Do something

  }

Use a single space before and after each operator and brackets.

Good:

  if ( showResult == true )
  {
   for ( int i = 0; i < 10; i++ )
   {
    //

   }
  }

Not good:

  if(showResult==true)
  {
   for(int i= 0;i<10;i++)
   {
    //

   }
  }

Good Programming Practices

Avoid having too-large files. If a file has more than 300-400 lines of code, you must consider refactoring the code into helper classes. Avoid writing very long methods. A method should typically have 1-25 lines of code. If a method has more than 25 lines of code, you must consider refactoring it into separate methods. The method's name should tell what it does. Do not use misleading names. If the method name is obvious, there is no need of documentation explaining what the method does.

Good:

void SavePhoneNumber ( string phoneNumber )
{
  // Save the phone number.

}

Not good:

 // This method will save the phone number.

 void SaveData ( string phoneNumber )
 {
  // Save the phone number.

 }

A method should do only "one job." Do not combine more than one job in a single method, even if those jobs are very small.

Good:

 // Save the address.

 SaveAddress (  address );
 
 // Send an email to the supervisor to inform that the address is updated.

 SendEmail ( address, email );  
 
 void SaveAddress ( string address )
 {
  // Save the address.

  // ...

 }
 
 void SendEmail ( string address, string email )
 {
  // Send an email to inform the supervisor that the address is changed.

  // ...

 }

Not good:

 // Save address and send an email to the supervisor

 // to inform that the address is updated.

 SaveAddress ( address, email );
 void SaveAddress ( string address, string email )
 {
  // Job 1.

  // Save the address.

  // ...

 // Job 2.

  // Send an email to inform the supervisor that the address is changed.

  // ...

 }

Use the C# or VB.NET specific types, rather than the alias types defined in theSystemnamespace.

Good:

 int age;
 string name;
 object contactInfo;

Not good:

 Int16 age;
 String name;
 Object contactInfo;

Do not hardcode numbers. Use constants instead. Do not hardcode strings. Use resource files. Avoid using many member variables. Declare local variables and pass them to methods instead of sharing a member variable between methods. If you share a member variable between methods, it will be difficult to track which method changed the value and when. Useenumwherever required. Do not use numbers or strings to indicate discrete values.

Good:

enum MailType
 {
  Html,
  PlainText,
  Attachment
 }
 void SendMail (string message, MailType mailType)
 {
  switch ( mailType )
  {
   case MailType.Html:
    // Do something

    break;
   case MailType.PlainText:
    // Do something

    break;
   case MailType.Attachment:
    // Do something

    break;
   default:
    // Do something

    break;
  }
 }

Not good:

void SendMail (string message, string mailType)
{
  switch ( mailType )
  {
   case "Html":
    // Do something

    break;
   case "PlainText":
    // Do something

    break;
   case "Attachment":
    // Do something

    break;
   default:
    // Do something

    break;
  }
}

Do not make the member variablespublicorprotected. Keep themprivateand exposepublic/protectedproperties. Never hardcode a path or drive name in code. Get the application path programmatically and use relative path. Never assume that your code will run from driveC:. You never know; some users may run it from a network or from aZ:.

In the application start-up, do some kind of "self check" and ensure that all required files and dependencies are available in the expected locations. Check for database connections at start-up, if required. Give a friendly message to the user in case of any problems.

If the required configuration file is not found, the application should be able to create one with default values. If a wrong value is found in the configuration file, the application should throw an error or give a message and also should tell the user what the correct values are.

Error messages should help the user to solve the problem. Never give error messages like "Error in Application," "There is an error," etc. Instead, give specific messages like "Failed to update database. Please make sure the login ID and password are correct."

When displaying error messages, in addition to telling what is wrong, the message should also tell what the user should do to solve the problem. Instead of a message like "Failed to update the database," suggest what the user should do: "Failed to update database. Please make sure the login ID and password are correct."

Show short and friendly messages to the user, but log the actual error with all possible information. This will help a lot in diagnosing problems.

Comments

Do not write comments for every line of code and every variable declared. Write comments wherever required. Good, readable code will require very few comments. If all variables and method names are meaningful, that will make the code very readable and it will not need much commenting. Fewer lines of comments will make the code more elegant. However, if the code is not clean/readable and there are fewer comments, that is worse. If you have to use some complex or weird logic for any reason, document it very well with sufficient comments. If you initialize a numeric variable to a special number other than 0, -1, etc., document the reason for choosing that value. The bottom line is: write clean, readable code in such a way that it doesn't need any comments to understand it. Do a spell check on comments and also make sure that proper grammar and punctuation are used.

Exception Handling

Never do a "catch exception and do nothing." If you hide an exception, you will never know if the exception happened or not. In the case of exceptions, give a friendly message to the user, but log the actual error with all possible details about the error, including the time it occurred, the method and class name, etc. Always catch only the specific exception, not generic exceptions.

Good:

void ReadFromFile ( string fileName )
 {
  try
  {
   // read from file.

  }
  catch (FileIOException ex)
  {
   // log error.

   //  re-throw exception depending on your case.

   throw;
  }
 }

Not good:

void ReadFromFile ( string fileName )
{
  try
  {
    // read from file.

  }
  catch (Exception ex)
  {
    // Catching general exception is bad... we will never know whether it

    // was a file error or some other error.


    // Here you are hiding an exception.

    // In this case no one will ever know that an exception happened.

    return "";
  }
}

There's no need to catch the general exception in all your methods. Leave it open and let the application crash. This will help you find most of the errors during the development cycle. You can have an application level (thread level) error handler where you can handle all general exceptions. In the case of an "unexpected general error," this error handler should catch the exception and should log the error, in addition to giving a friendly message to the user before closing the application or allowing the user to "ignore and proceed."

Do not writetry-catchin all your methods. Use it only if there is a possibility that a specific exception may occur. For example, if you are writing into a file, handle onlyFileIOException.

Do not write very largetry-catchblocks. If required, write a separatetry-catchfor each task you perform and enclose only the specific piece of code inside thetry-catch. This will help you find which piece of code generated the exception and you can give specific error messages to the user.

You may write your own custom exception classes, if required, in your application. Do not derive your custom exceptions from the base classSystemException. Instead, inherit fromApplicationException.

License

This article has no explicit license attached to it but may contain usage terms in the article text or the download files themselves. If in doubt please contact the author via the discussion board below.

A list of licenses authors might use can be foundhere


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics