`

PAT 1019. General Palindromic Number (20)

    博客分类:
  • PAT
 
阅读更多

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

#include<stdio.h>
int main(){
	long long n, b;
	int a[1000];
	scanf("%Ld%Ld\n", &n,&b);
	int index = 0;
	while(n != 0){
		a[index++] = n%b;
		n /= b;
	}
	int i = 0;
	int j = index - 1;
	int flag = 0;
	while(i<j){
		if(a[i] != a[j]){
			flag = 1;
			break;
		}
		i++;
		j--;
	}
	if(flag)
		printf("No\n");
	else
		printf("Yes\n");
	for(i =index-1; i> 0; i--){
		printf("%d ", a[i]);
	}
	printf("%d\n", a[0]);
	return 0;
}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics