`
richard_ma
  • 浏览: 15286 次
最近访客 更多访客>>
社区版块
存档分类
最新评论

HDU1003最大连续子序列和

阅读更多
Max Sum

http://acm.hdu.edu.cn/showproblem.php?pid=1003

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

这是一类典型的动态规划题目,一维数组。

将数组中的数字逐一相加。
如果发现当前的和小于0,则抛弃前面一段,将sum重置为0。记录下一个为准最大段起始位置。
如果和大于等于0,则加上这一段。
如果和大于最大值max,记录这个max值,并更新最大段其实和终止位置。

注:
max初值必须小于数组中数据的最小值。
此题输出格式,当有多个测试用例的时候,最后一个不允许出现多余空行,其它相邻两个用例间加入一个空行。

#include <stdio.h>
#include <stdlib.h>

int main (int argc, char const* argv[])
{
    int i, c, t, n, sum, max, first, last, temp;
    int a[100000];

    scanf("%d", &t);

    c = 1;
    while (c <= t) {
        scanf("%d", &n);

        for (i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }

        sum = 0; max = -1001;
        first = 0; last = 0; temp = 1;
        for (i = 0; i < n; i++) {
            sum += a[i];

            if (sum > max) {
                max = sum;
                first = temp;
                last = i + 1;
            }

            if (sum < 0) {
                sum = 0;
                temp = i + 2;
            }
        }

        printf("Case %d:\n", c);
        printf("%d %d %d\n", max, first, last);
        if (c != t) printf("\n");

        c++;
    }

    return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics