`

(hdu1001)Sum Problem

阅读更多
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

import java.io.*;
import java.util.*;

public class Main
{
    public static void main(String args[])
    {
        Scanner cin = new Scanner(System.in);
        int n;

        while(cin.hasNextInt())
        {
            n = cin.nextInt();
            
            System.out.println(sum(n));
            System.out.println();
            
        }
    }
    
    public static int sum(int n) {
    	if(n % 2 == 0) {
    		return (n / 2) * (n + 1);
    	} else {
    		return ((n + 1) / 2) * n;
    	}
    }
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics