`
Simone_chou
  • 浏览: 184853 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Agri-Net(最小生成树 + 并查集)

 
阅读更多
Agri-Net
Russ Cox

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

PROGRAM NAME: agrinet

INPUT FORMAT

Line 1: The number of farms, N (3 <= N <= 100).
Line 2..end: The subsequent lines contain the N x N connectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

SAMPLE INPUT (file agrinet.in)

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

OUTPUT FORMAT

The single output contains the integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

SAMPLE OUTPUT (file agrinet.out)

28

 

      题意:

      给出 N (3 ~ 100),后给出矩阵 N X N,代表 i 到 j 的距离。求最小生成树。

 

      思路:

      Kruskal。刚学并查集的时候写过一遍,重新写了一遍,对比下代码风格。

 

      AC:

/*
TASK:agrinet
LANG:C++
ID:sum-g1
*/

#include <cstdio>
#include <algorithm>
using namespace std;

typedef struct {
    int u, v, l;
}node;

node no[10005];
int root[105];

int cmp(node a, node b) {
        return a.l < b.l;
}

int Find(int x) {
        return x == root[x] ? x : root[x] = Find(root[x]);
}

int main() {
    freopen("agrinet.in", "r", stdin);
    freopen("agrinet.out", "w", stdout);

    int n, sum = 0;

    scanf("%d",&n);

    for (int i = 1; i <= n; ++i)
            root[i] = i;

    for (int i = 1; i <= n; ++i)
            for (int j = 1; j <= n; ++j) {
                    int ans;
                    scanf("%d",&ans);
                    if (ans) {
                            no[sum].u = i;
                            no[sum].v = j;
                            no[sum].l = ans;
                            sum++;
                    }
            }

    sort(no,no + sum,cmp);

    int ans = 0;
    for (int i = 0; i < sum; ++i) {
            int fa = Find(no[i].u);
            int fb = Find(no[i].v);
            if (fa != fb) {
                    ans += no[i].l;
                    root[fa] = fb;
            }
    }

    printf("%d\n", ans);
    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics