`
Simone_chou
  • 浏览: 184847 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Score Inflation(完全背包)

 
阅读更多
Score Inflation

The more points students score in our contests, the happier we here at the USACO are. We try to design our contests so that people can score as many points as possible, and would like your assistance.

We have several categories from which problems can be chosen, where a "category" is an unlimited set of contest problems which all require the same amount of time to solve and deserve the same number of points for a correct solution. Your task is write a program which tells the USACO staff how many problems from each category to include in a contest so as to maximize the total number of points in the chosen problems while keeping the total solution time within the length of the contest.

The input includes the length of the contest, M (1 <= M <= 10,000) (don't worry, you won't have to compete in the longer contests until training camp) and N, the number of problem categories, where 1 <= N <= 10,000.

Each of the subsequent N lines contains two integers describing a category: the first integer tells the number of points a problem from that category is worth (1 <= points <= 10000); the second tells the number of minutes a problem from that category takes to solve (1 <= minutes <= 10000).

Your program should determine the number of problems we should take from each category to make the highest-scoring contest solvable within the length of the contest. Remember, the number from any category can be any nonnegative integer (0, one, or many). Calculate the maximum number of possible points.

PROGRAM NAME: inflate

INPUT FORMAT

Line 1: M, N -- contest minutes and number of problem classes
Lines 2-N+1: Two integers: the points and minutes for each class

SAMPLE INPUT (file inflate.in)

300 4
100 60
250 120
120 100
35 20

OUTPUT FORMAT

A single line with the maximum number of points possible given the constraints.

SAMPLE OUTPUT (file inflate.out)

605

(Take two problems from #2 and three from #4.) 

 

      题意:

      给出 M(1 ~ 10000),N(1 ~ 10000),代表时间限制是 M ,给出 N 个题目类型。后给出这 N 个题目类型的分数和时间,选择答题类型可以无限次,问在规定时间内如何选取类型使得最后得到的分数最高。

  

      思路:

      完全背包。

 

      AC:

/*
TASK:inflate
LANG:C++
ID:sum-g1
*/

#include <cstdio>
#include <algorithm>
#include <cstring>
#define MAX 10005
using namespace std;

typedef long long ll;

int t[MAX], w[MAX];
ll dp[MAX];

int main() {
    freopen("inflate.in", "r", stdin);
    freopen("inflate.out", "w", stdout);

    int m, n;
    scanf("%d%d", &m, &n);

    for (int i = 1; i <= n; ++i)
            scanf("%d%d", &w[i], &t[i]);

    memset(dp, 0, sizeof(dp));

    for (int i = 1; i <= n; ++i)
            for (int j = t[i]; j <= m; ++j)
                    dp[j] = max(dp[j - t[i]] + w[i],dp[j]);

    printf("%lld\n",dp[m]);

    return 0;
}

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics