`
Simone_chou
  • 浏览: 184697 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

233 Matrix(矩阵快速幂)

    博客分类:
  • HDOJ
 
阅读更多

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 553    Accepted Submission(s): 345


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a0,1 = 233,a0,2 = 2333,a0,3 = 23333...) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,...,an,0, could you tell me an,m in the 233 matrix?
 

 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,...,an,0(0 ≤ ai,0 < 231).
 

 

Output
For each case, output an,m mod 10000007.
 

 

Sample Input
1 1
1
2 2
0 0
3 7
23 47 16
 

 

Sample Output

 

234
2799
72937
Hint

 

       题意:

       有个 N 行 M 列的矩阵,给出第一行和第一列的元素,根据 a [ i ] [ j ] = a [ i - 1 ] [ j ] + a [ i ] [ j - 1 ] 求出 a [ n ] [ m ] 元素是什么。

 

       思路:

       矩阵快速幂。详细题解明天再补回。记得要用 long long。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

typedef long long ll;
typedef vector<ll> vec;
typedef vector<vec> mat;

const ll MOD = 10000007;

ll n, m;

mat mul (mat a, mat b) {
    mat c(n + 2, vec(n + 2));

    for (ll i = 0; i < n + 2; ++i) {
        for (ll j = 0; j < n + 2; ++j) {
            for (ll k = 0; k < n + 2; ++k) {
                c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % MOD;
            }
        }
    }

    return c;
}

mat pow (mat a) {
    mat b(n + 2, vec(n + 2));
    for (ll i = 0; i < n + 2; ++i) {
        b[i][i] = 1;
    }

    while (m > 0) {
        if (m & 1) b = mul(b, a);
        a = mul(a, a);
        m >>= 1;
    }

    return b;
}

int main () {

    while (~scanf("%I64d%I64d", &n, &m)) {
        mat a(n + 2, vec(n + 2));
        mat b(n + 2, vec(1));

        a[0][0] = 10, a[0][1] = a[1][1] = 1;
        for (ll i = 2; i < n + 2; ++i) {
            for (ll j = 0; j < n + 2; ++j) {
                if (j <= i) a[i][j] = 1;
                if (!j) a[i][j] = 10;
            }
        }

        b[0][0] = 23, b[1][0] = 3;
        for (ll i = 0; i < n; ++i) {
            scanf("%I64d", &b[i + 2][0]);
            b[i + 2][0] %= MOD;
        }

        a = pow(a);
        b = mul(a, b);

        printf("%I64d\n", b[n + 1][0]);
    }

    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics