`
Simone_chou
  • 浏览: 184682 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Saving Tang Monk(BFS)

    博客分类:
  • HDOJ
 
阅读更多

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 579    Accepted Submission(s): 217


Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M).

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

 

Sample Input
3 1
K.S
##1
1#T
3 1
K#T
.S#
1#.
3 2
K#T
.S.
21.
0 0
 

 

Sample Output

 

5
impossible
8

       题意:

       给出 N(0 ~ 100),M(0 ~ 9),代表有 N * N 的地图,且需要 M 号钥匙才能到达 T,K 代表起点,S 代表障碍,障碍可以攻击掉再走。K 需要收集 i 号钥匙才能收集 i + 1 号,问 K 最小多少步到达 T。可能存在多个 i 类钥匙,也可能出现多个 S,最多 5 个。

 

       思路:

       BFS。用数组记录 S 记录路径 S 是否被杀死过。从 1 -> 2 -> 3 …… -> M -> T 搜索。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int INF = 99999999;

typedef struct {
    int S[50];
    int x, y, len;
} state;

int Map[105][105];
int n, m, kx, ky, tx, ty, s_num;
int dir[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};
bool vis[105][105];

void bfs () {
    state from;
    memset(from.S, 0, sizeof(from.S));
    from.x = kx, from.y = ky, from.len = 0;

    queue<state> fin;
    fin.push(from);

    while (!fin.empty()) {
        state x = fin.front();

        if (Map[x.x][x.y] == m + 1) break;

        fin.pop();

        memset(vis, 0, sizeof(vis));
        queue<state> q;
        q.push(x);
        while (!q.empty()) {
            state xx = q.front(); q.pop();

            if (Map[xx.x][xx.y] == Map[x.x][x.y] + 1) {
                fin.push(xx);
                continue;
            }

            state y;
            for (int i = 0; i < 4; ++i) {
                y.x = xx.x + dir[i][0];
                y.y = xx.y + dir[i][1];

                for (int i = 0; i < s_num; ++i)
                    y.S[i] = xx.S[i];

                if (y.x >= 1 && y.x <= n &&
                    y.y >= 1 && y.y <= n &&
                    !vis[y.x][y.y] && Map[y.x][y.y] != -1) {
                        vis[y.x][y.y] = true;
                        y.len = xx.len + 1;

                        if (Map[y.x][y.y] >= 20 &&
                            !xx.S[ Map[y.x][y.y] - 20 ])
                            y.S[ Map[y.x][y.y] - 20 ] = 1;

                        q.push(y);
                    }
            }

        }

    }

    if (fin.empty()) {
        printf("impossible\n");
        return;
    }

    int Min = INF;
    while (!fin.empty()) {
        state a = fin.front(); fin.pop();

        int ans = 0;
        for (int i = 0; i < s_num - 20; ++i) {
            if (a.S[i]) ++ans;
        }

        Min = min(Min, a.len + ans);
    }

    printf("%d\n", Min);
    return;

}

int main() {

    while (~scanf("%d%d", &n, &m) && (n + m)) {

        s_num = 20;

        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= n; ++j) {
                char c;
                scanf(" %c", &c);

                if (c <= '9' && c >= '1') Map[i][j] = c - '0';
                if (c == '.') Map[i][j] = 11;
                if (c == '#') Map[i][j] = -1;
                if (c == 'S') Map[i][j] = s_num++;
                if (c == 'K') Map[i][j] = 0;
                if (c == 'T') Map[i][j] = m + 1;

                if (!Map[i][j]) {
                    kx = i, ky = j;
                } else if (Map[i][j] == m + 1) {
                    tx = i, ty = j;
                }
            }
        }

        bfs ();

    }

    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics