`
Simone_chou
  • 浏览: 186706 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Just a Hook(线段树 + 延迟标记)

    博客分类:
  • HDOJ
 
阅读更多

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16232    Accepted Submission(s): 8075


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1
10
2
1 5 2
5 9 3
 

 

Sample Output

 

Case 1: The total value of the hook is 24.

 

       题意:

       给出 T 组 case,后给出 N(1 ~ 100000) ,代表有 N 个为 1 的数,后给出 M,代表有 M 个操作,每个操作有 l,r,ans,代表将 l 到 r 区间的数变为 ans,在处理完所有操作之后,输出整个序列和的结果。

 

       思路:

       线段树 + 区间更新。延迟标记记录每段变为 ans 时候的值,理解了新的写法。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 100000 * 5;

int tree[MAX], mark[MAX];

void pushup (int node) {
        tree[node] = tree[node << 1] +  tree[node << 1 | 1];
}

void pushdown (int node, int l, int r) {
        if (mark[node]) {
                int mid = (r + l) >> 1;

                mark[node << 1] = mark[node];
                mark[node << 1 | 1] =  mark[node];

                tree[node << 1] = (mid - l + 1) * mark[node];
                tree[node << 1 | 1] = (r - mid) * mark[node];

                mark[node] = 0;
        }
}

void build (int node, int l, int r) {
        int mid = (l + r) >> 1;

        if (l == r) {
                tree[node] = 1;
                mark[node] = 0;
        } else {
                build(node << 1, l, mid);
                build(node << 1 | 1, mid + 1, r);

                pushup(node);
                mark[node] = 0;
        }

}

void update (int node, int l, int r, int cl, int cr, int num) {

        if (cl > r || cr < l) return;
        if (cl <= l && cr >= r) {
                mark[node] = num;
                tree[node] = (r - l + 1) * num;
                return;
        }

        pushdown(node, l, r);
        
        int mid = (r + l) >> 1;
        update(node << 1, l, mid, cl, cr, num);
        update(node << 1 | 1, mid + 1, r, cl, cr, num);

        pushup(node);
}

int main() {
        int t;
        scanf("%d", &t);

        for (int tt = 1; tt <= t; ++tt) {

                int n;
                scanf("%d", &n);
                build(1, 1, n);

                int m;
                scanf("%d", &m);
                while (m--) {
                        int al, ar, ans;
                        scanf("%d%d%d", &al, &ar, &ans);
                        update(1, 1, n, al, ar, ans);
                }

                printf("Case %d: The total value of the hook is %d.\n",
                        tt, tree[1]);

        }

        return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics