`
hellobin
  • 浏览: 62721 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 457 - Linear Cellular Automata

    博客分类:
  • UVA
 
阅读更多

 

A biologist is experimenting with DNA modification of bacterial colonies being grown in a linear array of culture dishes. By changing the DNA, he is able ``program" the bacteria to respond to the population density of the neighboring dishes. Population is measured on a four point scale (from 0 to 3). The DNA information is represented as an arrayDNA, indexed from 0 to 9, of population density values and is interpreted as follows:

 

  • In any given culture dish, letKbe the sum of that culture dish's density and the densities of the dish immediately to the left and the dish immediately to the right. Then, by the next day, that dish will have a population density ofDNA[K].
  • The dish at the far left of the line is considered to have a left neighbor with population density 0.
  • The dish at the far right of the line is considered to have a right neighbor with population density 0.

     

Now, clearly, some DNA programs cause all the bacteria to die off (e.g., [0,0,0,0,0,0,0,0,0,0]). Others result in immediate population explosions (e.g., [3,3,3,3,3,3,3,3,3,3]). The biologist is interested in how some of the less obvious intermediate DNA programs might behave.

 

Write a program to simulate the culture growth in a line of 40 dishes, assuming that dish 20 starts with a population density of 1 and all other dishes start with a population density of 0.

 

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

For each input set your program will read in the DNA program (10 integer values) on one line.

 

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each input set it should print the densities of the 40 dishes for each of the next 50 days. Each day's printout should occupy one line of 40 characters. Each dish is represented by a single character on that line. Zero population densities are to be printed as the character ` '. Population density 1 will be printed as the character `.'. Population density 2 will be printed as the character `x'. Population density 3 will be printed as the character `W'.

 

Sample Input

 

1

0 1 2 0 1 3 3 2 3 0

 

Sample Output

 

bbbbbbbbbbbbbbbbbbb.bbbbbbbbbbbbbbbbbbbb
bbbbbbbbbbbbbbbbbb...bbbbbbbbbbbbbbbbbbb
bbbbbbbbbbbbbbbbb.xbx.bbbbbbbbbbbbbbbbbb
bbbbbbbbbbbbbbbb.bb.bb.bbbbbbbbbbbbbbbbb
bbbbbbbbbbbbbbb.........bbbbbbbbbbbbbbbb
bbbbbbbbbbbbbb.xbbbbbbbx.bbbbbbbbbbbbbbb
bbbbbbbbbbbbb.bbxbbbbbxbb.bbbbbbbbbbbbbb
bbbbbbbbbbbb...xxxbbbxxx...bbbbbbbbbbbbb
bbbbbbbbbbb.xb.WW.xbx.WW.bx.bbbbbbbbbbbb
bbbbbbbbbb.bbb.xxWb.bWxx.bbb.bbbbbbbbbbb

Note:Whe show only the first ten lines of output (the total number of lines must be 50) and the spaces have been replaced with the character"b"for ease of reading. The actual output file will use the ASCII-space character, not"b".

 

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105
int dna[10];
int buf[50][40];


void printout(){
	for(int i=0; i<50; i++){
		for(int j=0; j<40; j++){
			switch(buf[i][j]){
			case 0:
				printf(" ");
				break;
			case 1:
				printf(".");
				break;
			case 2:
				printf("x");
				break;
			case 3:
				printf("W");
				break;
			default:
				printf("?");
				break;
			}
		}
		printf("\n");
	}

}


void play(){

	memset(buf, 0, sizeof(buf));
	buf[0][19] = 1;

	for(int i=1; i<50; i++){
		for(int j=0; j<40; j++){
			int cnt = 0;
			for(int k=j-1; k<=j+1; k++){
				if(k>=0 && k<=39){
					cnt += buf[i-1][k];
				}
			}
			buf[i][j] = dna[cnt];
		}
	}

	printout();
}



int main(){

#ifndef ONLINE_JUDGE
	freopen("457.in", "r", stdin);
	freopen("457.out", "w", stdout); 
#endif

	int n;

	scanf("%d", &n);
	getchar();

	for(int i=0; i<n; i++){
		getchar();
		memset(dna, 0, sizeof(dna));
		for(int j=0; j<10; j++){
			scanf("%d", &dna[j]);
		}
		getchar();

		play();
		if(i != n-1){
			printf("\n");
		}
	}


}


#endif



 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics