`
hellobin
  • 浏览: 62716 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 129 - Krypton Factor

    博客分类:
  • UVA
 
阅读更多

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

 

  • BB
  • ABCDACABCAB
  • ABCDABCD

Some examples of hard sequences are:

 

  • D
  • DC
  • ABDAB
  • CBABCBA

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:

 


AB 
ABA 
ABAC 
ABACA 
ABACAB 
ABACABA

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

 

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

 

Sample Input

 

30 3
0 0

 

Sample Output

 

ABAC ABCA CBAB CABA CABC ACBA CABA
28

 

类似8皇后问题的回溯法。

这里贴出判断的例子流程:

cur=0
0 

===============
cur=1
01

j=1

k=0:
if(S[cur-k] != S[cur-k-j])
if(S[1] != S[0])

================
cur=2
010

j=1
k=0

=================
cur=3


j=1
k=0
s[3] == S[2]


j=2
k=0,1
S[3] == S[1]
S[2] == S[0]

  cur-j     cur
0 1     0   0

 

 

特别注意要按照格式输出

 

#define RUN
#ifdef RUN

#include <stdio.h>  
#include <stdlib.h>  
#include <string.h>  
#include <assert.h>  
#include <string>  
#include <iostream>  
#include <sstream>  
#include <map>  
#include <set>  
#include <vector>  
#include <list>  
#include <cctype>   
#include <algorithm>  
#include <utility>  
#include <math.h>  
#include <ctime>  
using namespace std;

int n, L, cnt = 0;

//全局辅助数组
int S[100];

// 返回0表示已经得到解,无须继续搜索
int dfs(int cur) {

  //最后生成的字符串长度为n
  if(cnt++ == n) {
	  // 输出方案
	  int totalGroups = 0;
	  int groups = 0;
	  int groupLim = 16;

	  //cout << cur/(4) << endl;
	  for(int i = 0; i < cur; i++){
		  printf("%c", 'A'+S[i]);
		  if((i+1)%4==0){
			  groups++;
			  totalGroups++;
			  if(groups >= groupLim){
				  groups = 0;
				  printf("\n");
			  }
			  else{

				  if(totalGroups != ceil(cur/4.0)){
					  printf(" ");
				  }
			  }
		  }
	  }

	  printf("\n");
	  printf("%d\n", cur);
	  return 0;
  }

  //依次尝试长度为L内的字符串,eg:L=3,则尝试i=0,1,2
  for(int i = 0; i < L; i++) {
    S[cur] = i;
    int ok = 1;

	// 尝试长度为j*2的后缀(从cur的位置进行比较在cur前面j*2个元素(包括cur元素)是否会相等)
    for(int j = 1; j*2 <= cur+1; j++) {

      int equal = 1;
	  
	  //对cur前j*2个元素遍历比较
      for(int k = 0; k < j; k++){
		  // 检查后一半是否等于前一半
		  if(S[cur-k] != S[cur-j-k]) {
			  equal = 0; break; 
		  }
	  }

      // 后一半等于前一半,方案不合法,因为我们要产生"困难的串"
      if(equal) {
		  ok = 0; break; 
	  }
    }


    if(ok){
		if(!dfs(cur+1)) return 0;                     // 递归搜索。如果已经找到解,则直接退出
	}
  }

  return 1;
}

int main() {

#ifndef ONLINE_JUDGE
	freopen("129.in", "r", stdin);
	freopen("out.out", "w", stdout); 
#endif


	while(scanf("%d%d", &n, &L)!=EOF && n && L){
		
		memset(S, 0, sizeof(S));
		int cur = 0;
		cnt = 0;
		dfs(cur);
	}


	return 0;
}

#endif

 

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics