`
hellobin
  • 浏览: 62723 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 414 - Machined Surfaces

    博客分类:
  • UVA
 
阅读更多

An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

 

A digital image is composed of the two characters,"X"and" "(space). There are always 25 columns to an image, but the number of rows,N, is variable. Column one (1) will always have an"X"in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguousX's.

 

Similarly, column 25 will always have an"X"in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguousX's.

Digital-Image View of Surfaces

 

 
		 Left     		                           Right

 

XXXX XXXXX tex2html_wrap_inline50

XXX XXXXXXX

XXXXX XXXX

XX XXXXXX

. .

. .

. .

XXXX XXXX

XXX XXXXXX tex2html_wrap_inline52

tex2html_wrap_inline54tex2html_wrap_inline56

1 25

In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blankregionin any row.

 

For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact.

 

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost"X"of the left surface of some row is immediately to the left of the leftmost"X"of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

 

 

Note:The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

 

Input

The input consists of a series of digital images. Each image data set has the following format:

 

First line -
A single unsigned integer,N, with value greater than zero (0) and less than 13. The first digit ofNwill be the first character on a line.

 

NextNlines -
Each line has exactly 25 characters; one or moreX's, then zero or more spaces, then one or moreX's.

 

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

 

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

 

Sample Input(character"B"for ease of reading. The actual input file will use the ASCII-space character, not"B").

 

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0

 

Sample Output

 

4
0
0

总结
1)空格是' '而不是'B'
2)fgets会读入'\n', scanf只会读到空白(' ','\n',etc)之前,需要用getchar()来读过回车



#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 1000

char input[MAXN];
int empty[14];

int main(){

#ifndef ONLINE_JUDGE
	freopen("414.in", "r", stdin);
	freopen("414.out", "w", stdout); 
#endif

	
	int n;

	while(scanf("%d", &n)==1 && (n!=0)){
		// Read '\n'
		getchar();
		int minEmpty = 32767;
		memset(empty, 0, sizeof(empty));
		for(int i=0; i<n; i++){
			memset(input, 0, sizeof(input));

			fgets(input, MAXN, stdin);
			//scanf("%s", input);
			//printf("%s\n", input);

			// Count the number of empty spaces ' ' in the input string
			for(int j=0; j<strlen(input); j++){
				if(input[j] == ' '){
					empty[i]++;
				}
			}

			// Get the minimum number of Bs
			if(empty[i] < minEmpty){
				minEmpty = empty[i];
			}
		}

		int remain = 0;
		for(int i=0; i<n; i++){
			remain += (empty[i]-minEmpty);
		}

		printf("%d\n", remain);
	}




}


#endif

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics