`
joe_zxy
  • 浏览: 43355 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.1326】

    博客分类:
  • ACM
阅读更多
Mileage Bank
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8410 Accepted: 3423

Description

Mileage program of ACM (Airline of Charming Merlion) is really nice for the travelers flying frequently. Once you complete a flight with ACM, you can earn ACMPerk miles in your ACM Mileage Bank depended on mileage you actual fly. In addition, you can use the ACMPerk mileage in your Mileage Bank to exchange free flight ticket of ACM in future.



The following table helps you calculate how many ACMPerk miles you can earn when you fly on ACM.
When you fly ACM		 Class Code	          You'll earn

 

First Class			 F		 Actual mileage + 100% mileage Bonus

 

Business Class		   	 B		 Actual mileage + 50% mileage Bonus

 

Economy Class			 Y

1-500 miles					 500 miles

500+ miles					 Actual mileage

It's shown that your ACMPerk mileage consists of two parts. One is your actual flight mileage (the minimum ACMPerk mileage for Economy Class for one flight is 500 miles), the other is the mileage bonus (its accuracy is up to 1 mile) when you fly in Business Class and First Class. For example, you can earn 1329 ACMPerk miles, 1994 ACMPerk miles and 2658 ACMPerk miles for Y, B or F class respectively for the fly from Beijing to Tokyo (the actual mileage between Beijing and Tokyo is 1329 miles). When you fly from Shanghai to Wuhan, you can earn ACMPerk 500 miles for economy class and ACMPerk 650 miles for business class (the actual mileage between Shanghai and Wuhan is 433 miles).



Your task is to help ACM build a program for automatic calculation of ACMPerk mileage.

Input

The input file contains several data cases. Each case has many flight records, each per line. The flight record is in the following format:

OriginalCity DistanceCity ActualMiles ClassCode

Each case ends with a line of one zero.

A line of one # presents the end of the input file.

Output

Output the summary of ACMPerk mileages for each test case, one per line.

Sample Input

Beijing Tokyo 1329 F
Shanghai Wuhan 433 Y
0
#

Sample Output

3158

Hint

When calculate bonus ,be sure you rounded x.5 up to x+1

 

此题的关键在于每次计算Bonus的时候进行四舍五入

 

import java.util.*;
import java.text.*;

class FRecord
{
	String from;
	String to;
	int miles;
	String type;
	
	public FRecord(String a, String b, int c, String d)
	{
		this.from = a;
		this.to = b;
		this.miles = c;
		this.type = d;
	}
	
}

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		ArrayList record = new ArrayList();
		
		while(true)
		{
			String tmp = cin.nextLine();
			
			if(tmp.equals("#"))
				break;
			else if(tmp.equals("0"))
			{
				int total = getSummary(record);
				record.clear();
				System.out.println(total);
			}
			else
			{
				String[] str = tmp.split(" ");
				FRecord fr = new FRecord(str[0], str[1], 
						Integer.valueOf(str[2]).intValue(), str[3]);
				record.add(fr);
			}
		}
	}
	
	private static int getSummary(ArrayList record)
	{
		int result = 0;
		
		Iterator iter = record.iterator();
		while(iter.hasNext())
		{
			FRecord fr = (FRecord)iter.next();
			if(fr.type.equals("F"))
			{
				result += fr.miles * 2;
				DecimalFormat df = new DecimalFormat("#");
				result = Integer.valueOf(df.format(result)).intValue();
			}
			else if(fr.type.equals("B"))
			{
				result += fr.miles;
				result += (fr.miles + 1)/2;
				DecimalFormat df = new DecimalFormat("#");
				result = Integer.valueOf(df.format(result)).intValue();
			}
				
			else
			{
				if(fr.miles > 500)
				{
					result += fr.miles;
					DecimalFormat df = new DecimalFormat("#");
					result = Integer.valueOf(df.format(result)).intValue();
				}
					
				else
				{
					result += 500;
					DecimalFormat df = new DecimalFormat("#");
					result = Integer.valueOf(df.format(result)).intValue();
				}
					
			}
		}
		
		return result;
	}

}
 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics