`
joe_zxy
  • 浏览: 43354 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.3176】

    博客分类:
  • ACM
阅读更多
Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4594 Accepted: 2973

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

 

此题与1163雷同

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		int height = cin.nextInt();
		int[][] tree = new int[height][height]; 
		int[][] max = new int[height][height];
		int maxValue = 0;
		int left, right = 0;
		
		for(int i = 0; i < height; i++)
		{
			for(int j = 0; j <= i; j++)
			{
				tree[i][j] = cin.nextInt();
//				System.out.print(tree[i][j] + " ");
			}
//			System.out.println("\n");
		}
		
		max[0][0] = tree[0][0];
		

		
		for(int i = 1; i < height; i++)
		{
			for(int j = 0; j <= i; j++)
			{
				if(j == 0)
					max[i][j] = max[i-1][j] + tree[i][j];
				else if(j == i)
					max[i][j] = max[i-1][j-1] + tree[i][j];
				else
				{
					if(max[i-1][j-1] >= max[i-1][j])
						max[i][j] = max[i-1][j-1] + tree[i][j];
					else
						max[i][j] = max[i-1][j] + tree[i][j];
				}
			}
		}
		
		for(int j = 0; j < height; j++)
		{
			if(max[height-1][j] > maxValue)
				maxValue = max[height-1][j];
		}
		
		System.out.println(maxValue);
		

	}

}
 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics