`
Simone_chou
  • 浏览: 184611 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Atlantis(线段树 + 扫描线 + 离散化)

 
阅读更多
Atlantis
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16991   Accepted: 6479

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.
The input file is terminated by a line containing a single 0. Don't process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

 

       题意:

       给出 N (1 ~ 100),代表有 N 个矩形,后给出 N 个矩形的左下坐标值和右上坐标值,输出所有矩形所覆盖的面积和,面积和输出两位小数。直到输出 N = 0 结束。

 

       思路:

       线段树 + 扫描线 + 离散化。过程和求周长和类似,但是面积和就更简单了,不用保存覆盖的端点个数和区间左右端点的覆盖情况,因为面积完全只由长和宽决定,所以维护覆盖的长度和就好,并且统计的时候不用记录上一次的长度值,每次查询后再插入就行了。记得长度是浮点型的。

 

        AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const int MAX = 200000;

typedef struct {
        double x, y1, y2;
        int temp;
} node;

node line[105 * 2];
double yy[105 * 2];

double len[MAX * 3];
int cover[MAX * 3];

bool cmp(node a, node b) {
        if (a.x != b.x) return a.x < b.x;
        return a.temp > b.temp;
}

void push_up(int node, int l, int r) {
        if (cover[node]) len[node] = yy[r] - yy[l];
        else if (r - l == 1) len[node] =  0;
        else len[node] = len[node << 1] + len[node << 1 | 1];
}

void build (int node, int l, int r) {
        if (r - l == 1) {
                len[node] = 0;
        } else {
                int mid = (r + l) >> 1;
                build(node << 1, l, mid);
                build(node << 1 | 1, mid, r);
                push_up(node, l, r);
        }
}

void updata (int node, int l, int r, int cl, int cr, int c) {
        if (cl > r || cr < l) return;
        if (cl <= l && cr >= r) {
                cover[node] += c;
                push_up(node, l, r);
                return;
        }
        if (r - l == 1) return;

        int mid = (r + l) >> 1;
        updata(node << 1, l, mid, cl, cr, c);
        updata(node << 1 | 1, mid, r, cl, cr, c);
        push_up(node, l, r);
}

int main() {
        int n, t = 0;

        while (~scanf("%d", &n) && n) {
                int ans = 0, m = 0;

                while (n--) {
                        double x1, y1, x2, y2;
                        scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
                        line[ans].x = x1;
                        line[ans].y1 = y1;
                        line[ans].y2 = y2;
                        line[ans++].temp = 1;

                        line[ans].x = x2;
                        line[ans].y1 = y1;
                        line[ans].y2 = y2;
                        line[ans++].temp = -1;

                        yy[m++] = y1;
                        yy[m++] = y2;
                }

                sort(yy, yy + m);
                m = unique(yy, yy + m) - yy;

                sort(line, line + ans, cmp);
                build(1, 0, ans - 1);

                double res = 0;
                for (int i = 0; i < ans; ++i) {
                        int ll = lower_bound(yy, yy + m, line[i].y1) - yy;
                        int rr = lower_bound(yy, yy + m, line[i].y2) - yy;
                        if (i) {
                                double x, y;
                                x = line[i].x - line[i - 1].x;
                                y = len[1];
                                res += x * y;
                        }
                        updata(1, 0, ans - 1, ll, rr, line[i].temp);
                }

                printf("Test case #%d\n", ++t);
                printf("Total explored area: %.2lf\n\n", res);
        }

        return 0;
}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics