`
joe_zxy
  • 浏览: 43667 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.3673】

    博客分类:
  • ACM
阅读更多
Cow Multiplication
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4282 Accepted: 2847

Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A *B is equal to the sum of all possible pairwise products between the digits of A and B . For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input

* Line 1: Two space-separated integers: A and B .

Output

* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input

123 45

Sample Output

54

 

此种运算的思路即为ABC*XY = (A+B+C)*(X+Y),分开运算即可

 

import java.util.*;

public class Main {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		String[] str = null;
		String a = null;
		String b = null;

		int numa = 0;
		int numb = 0;
		
		while (cin.hasNext())
		{
			numa = 0;
			numb = 0;
			
			str = cin.nextLine().split(" ");
			a = str[0];
			b = str[1];
			
			for(int i = 0; i < a.length(); i++)
				numa = numa + Integer.valueOf(""+a.charAt(i));
			
			for(int j = 0; j < b.length(); j++)
				numb = numb + Integer.valueOf(""+b.charAt(j));
			
			System.out.println(numa * numb);
			
		}
	}

}
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics