`
Simone_chou
  • 浏览: 184640 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Subsequence(尺取法)

    博客分类:
  • POJ
 
阅读更多
Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8427   Accepted: 3281

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

  

     题意:

     给出 t 个 case,后给出 n (0 ~ 100000)个数 和 m 总和。求最小的序列长度,这个序列内的数的总和大于等于 m。输出这个长度。如果找不到则输出 0。

 

     思路:

     尺取法。反复推进区间的开头和末尾来求取满足条件的最小区间。

 

     AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const int MAX = 500000;

int num[100005];

int main() {

    int t;
    scanf("%d", &t);

    while (t--) {
        int n, m;
        scanf("%d%d", &n, &m);

        int len = MAX, sum = 0, from = 1;
        for (int i = 1; i <= n; ++i) {
            scanf("%d", &num[i]);
            sum += num[i];

            if (sum >= m) {
                while (sum - num[from] >= m && from <= i) {
                    sum -= num[from];
                    ++from;
                }

                len = min(len, i - from + 1);
            }
        }

        if(len == MAX) printf("0\n");
        else printf("%d\n", len);
    }

    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics