`
Simone_chou
  • 浏览: 184607 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Stockbroker Grapevine(Floyd)

    博客分类:
  • POJ
 
阅读更多
Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27232   Accepted: 15090

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

 

      题意:

      给出 n,代表有 n 个人,后有 n 行,每行首先有个 num,代表能传给 num 个人谣言,后给出 num 对数,分别代表传给人的编号和时间。现由一个人传开谣言,使之传播时间最少,输出起点还有时间。如果不存在这个人,则输出 disjoint。

 

      思路:

      Floyd 后,每个人都判断一遍即可,每个人的传播时间为 “ 传向除了自己的其他人中的最大所需时间 ” 。

 

      AC: 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>

using namespace std;

const int INF = 99999999;

int G[110][110];

void floyd (int n) {
    for (int k = 1; k <= n; ++k) {
        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= n; ++j) {
                if (G[i][j] > G[i][k] + G[k][j])
                    G[i][j] = G[i][k] + G[k][j];
            }
        }
    }
}

int main() {
    int n;

    while (~scanf("%d", &n) && n) {

        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= n; ++j) {
                G[i][j] = INF;
                if (i == j) G[i][j] = 0;
            }
        }

        for (int i = 1; i <= n; ++i) {
            int num;
            scanf("%d", &num);
            while (num--) {
                int k, t;
                scanf("%d%d", &k, &t);
                G[i][k] = min(t, G[i][k]);
            }
        }

        floyd(n);

        int min_time = INF, ans;
        for (int i = 1; i <= n; ++i) {
            int max_time = 0;
            for (int j = 1; j <= n; ++j) {
                if (j == i) continue;
                max_time = max(max_time, G[i][j]);
            }

            if (min_time > max_time) {
                min_time = max_time;
                ans = i;
            }
        }

        if (min_time == INF) printf("disjoint\n");
        else printf("%d %d\n", ans, min_time);
    }

    return 0;
}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics