`
Dev|il
  • 浏览: 121818 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU2251Seinfeld

 
阅读更多
Seinfeld
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 736    Accepted Submission(s): 381


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.



Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)




Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.



Sample Input
}{
{}{}{}
{{{}
---


Sample Output
1. 2
2. 0
3. 1
#include <iostream>
#include <string>
using namespace std;

const int MAX = 2010;
char a[MAX], b[MAX];
//题目大意:给一个字符串,通过交换字符,使其变的稳定 空串是稳定的 {},{{}} {{}{}}是稳定的,求最少交换次数
//栈的应用
int main()
{
	int t = 0, num, len, i, top;
	while(cin>>a && a[0] != '-')
	{
		top = num = 0;
		len = strlen(a);
		for(i = 0; i < len; i++)
		{
			//这里要注意防止 例如 //}{{{}} 出现处理后为}{{}
			if(a[i] == '{')
				b[top++] = a[i];
			else
			{
				if(top > 0)
				{
					if(b[top - 1] == '{')
						top--;
					else
						b[top++] = a[i];
				}else
					b[top++] = a[i];
			}
		}
		if(top == 0)
		{
			printf("%d. 0\n", ++t);
			continue;
		}
		//计算
		for(i = 0; i < top; i++)
		{
			if(b[i] == '}')
				num++;
			if(b[i + 1] == '{')
				num++;
			++i;
		}
		printf("%d. %d\n", ++t, num);
	}
	return 0;
}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics