`
Dev|il
  • 浏览: 121826 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU1711Number Sequence

 
阅读更多
Number Sequence
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3450    Accepted Submission(s): 1555


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.



Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].



Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.



Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


Sample Output
6
-1

题意:给两个数字序列a[1]......a[n],b[1]......b[m] 并且1 <= M <= 10000, 1 <= N <= 1000000,现在你的任务是找出b序列在a序列中存在的最小位置,和字符模式匹配一样

分析:如果用普通的字符模式匹配算法来解决此题会超时,显然应该用KMP算法
/**
**name:HDU1711
**result:Time Limit Exceeded
**author:Dev|il
**date:2011年9月9日 12:57
**/
#include <iostream>
using namespace std;

const int _N = 1000005;
const int _M = 10005;

int a[_N], b[_M];
int n, m;

int Index()
{
	int i = 0, j = 0;
	while(i < n && j < m)
	{
		if(a[i] == b[j])
		{
			++i;++j;
		}else
		{
			i = i - j + 1;
			j = 0;
		}
	}
	if(j == m)
		return i - m + 1;
	return -1;
}
int main()
{
	int t,  i;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		for(i = 0; i < n; i++)
			cin>>a[i];
		for(i = 0; i < m; i++)
			cin>>b[i];
		cout<<Index()<<endl;
	}
	return 0;
}


以下是AC代码,KMP算法
/**
**name:HDU1711
**result:Accept
**author:Dev|il
**date:2011年9月9日 13:9
**/
#include <iostream>
using namespace std;

const int _N = 1000005;
const int _M = 10005;

int a[_N], b[_M], next[_M];
int n, m;

void getNext()
{
	int i = 1, j = 0;
	next[1] = 0;
	while(i < m)
	{
		if(j == 0 || b[i] == b[j])
		{
			++i; ++j;
			next[i] = j;
		}else
			j = next[j];
	}
}
int Index()
{
	getNext();
	int i = 1, j = 1;
	while(i <= n && j <= m)
	{
		if(j== 0 || a[i] == b[j])
		{
			++i;++j;
		}
		else
			j = next[j];
	}
	if(j > m)
		return i - m;
	return -1;
}

int main()
{
	int t,  i;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		for(i = 1; i <= n; i++)
			cin>>a[i];
		for(i = 1; i <= m; i++)
			cin>>b[i];
		cout<<Index()<<endl;
	}
	return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics