`
Dev|il
  • 浏览: 121820 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU1004Let the Balloon Rise

 
阅读更多
Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31804    Accepted Submission(s): 10554


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.



Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.



Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output
red
pink


题意:计数颜色最多的气球,并输出颜色
#include <iostream>
using namespace std;

const int _N = 1005;
typedef struct{
	char c[20];
	int cns;
}B;

B b[_N];

int cmp(const void *a, const void *b)
{
	return strcmp((*(B*)a).c, (*(B*)b).c);
}
//计数题:
int main()
{
	int t, i, cns;
	B a;
	while(cin>>t, t)
	{
		for(i = 0; i < t; i++)
		{
			cin>>b[i].c;
			b[i].cns = -1;
		}
		qsort(b, t, sizeof(B), cmp);
		strcpy(a.c, b[0].c);
		for(i = 0, cns = 0; i < t; i++)
		{
			if(strcmp(a.c, b[i].c) != 0)
			{
				strcpy(a.c, b[i].c);
				b[i - 1].cns = cns;
				cns = 0;
			}
			cns++;
		}
		b[i - 1].cns = cns;
		a = b[0];
		for(i = 1; i < t; i++)
		{
			if(a.cns < b[i].cns)
				a = b[i];
		}
		printf("%s\n", a.c);
	}
	return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics