`
Dev|il
  • 浏览: 121808 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU1686Oulipo

 
阅读更多
Oulipo
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1554    Accepted Submission(s): 587


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.




Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.



Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.




Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN


Sample Output
1
3
0

题意:找出被匹配串中能匹配目标串的个数
#include <iostream>
using namespace std;

const int _N = 1000005;
const int _M = 10005;

char a[_M], b[_N];
int next[_M];
int n, m;

void getNext()
{
    int i = 1, j = 0;
    next[1] = 0;
    while(i <= n)
    {
        if(j == 0 || a[i] == a[j])
        {
            i++; j++;
			if(a[i] == a[j])
				next[i] = next[j];
			else
				next[i] = j;
        }else
            j = next[j];
    }
}

int Index_KMP()
{
    int i = 1, j = 1, num = 0;
    while(i <= m)
    {
        if(j == 0 || a[j] == b[i])
        {
            ++i; ++j;
        }else
            j = next[j];
		if(j == n + 1)
		{
			num++;
			j = next[j];
		}
    }
    return num;
}
int main()
{
    int t, i, cnt;
    cin>>t;
    while(t--)
    {
        getchar();
        cin>>a + 1>>b + 1;
        a[0] = '#';
        b[0] = '#';
        cnt = 0;
        n = strlen(a) - 1;
        m = strlen(b) - 1;
        getNext();
        cout<<Index_KMP()<<endl;
    }
    return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics