`
Dev|il
  • 浏览: 121821 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU3368 Reversi(黑白棋)

 
阅读更多
Reversi
Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 591    Accepted Submission(s): 251


Problem Description
Reversi, also called Othello, is a two-sided game.
Each of the two sides corresponds to one player; they are referred to here as light and dark after the sides of Othello pieces, but "heads" and "tails" would identify them equally as well, so long as each marker has sufficiently distinctive sides.
Originally, Reversi did not have a defined starting position. Later it adopted Othello's rules, which state that the game begins with four markers placed in a square in the middle of the grid, two facing light-up, two pieces with the dark side up. The dark player makes the first move.


Dark must place a piece with the dark side up on the board, in such a position that there exists at least one straight (horizontal, vertical, or diagonal) occupied line between the new piece and another dark piece, with one or more contiguous light pieces between them. In the below situation, dark has the following options indicated by transparent pieces:


After placing the piece, dark turns over (flips, captures) all light pieces lying on a straight line between the new piece and any anchoring dark pieces. All reversed pieces now show the dark side, and dark can use them in later moves—unless light has reversed them back in the meantime. In other words, a valid move is one where at least one piece is reversed.
If dark decided to put a piece in the topmost location (all choices are strategically equivalent at this time), one piece gets turned over, so that the board appears thus:


Now light plays. This player operates under the same rules, with the roles reversed: light lays down a light piece, causing a dark piece to flip. Possibilities at this time appear thus (indicated by transparent pieces):


Light takes the bottom left option and reverses one piece:


Players take alternate turns. If one player cannot make a valid move, play passes back to the other player. When neither player can move, the game ends. This occurs when the grid has filled up, or when one player has no more pieces on the board, or when neither player can legally place a piece in any of the remaining squares. The player with the most pieces on the board at the end of the game wins.
Now after several rounds, it’s dark’s turn. Can you figure out the largest number of light pieces he can turn over?



Input
The first line contains one integer T representing the number of test cases.
For each test case, there’re 8 lines. Each line contains 8 characters (D represents dark, L represents light, * represents nothing here).
Every two adjacent cases are separated by a blank line.



Output
For each test case, in one line print the case number and the largest number of light pieces the dark player can turn over. If he can’t put one piece in any position, then print 0.
Please follow the format of the sample output.



Sample Input
3
********
********
********
***LD***
***DL***
********
********
********

********
********
**DLL***
**DLLL**
**DLD***
********
********
********

********
********
*D******
*DLLD***
***LL***
**D*D***
********
********


Sample Output
Case 1: 1
Case 2: 3
Case 3: 0

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3368
AC代码:
#include <iostream>
using namespace std;

char map[10][10];
//八个方向
int dir[8][2] = {{0, 1}, {0, -1},{1, 0},{-1, 0},{1, 1},{-1, -1},{1, -1},{-1, 1}};

void dfs(int x, int y, int d, int num, int &sum)
{
	int i;
	if(x < 0 || x > 7 || y < 0 || y > 7)
		return;
	if(d == 8) //这个d值可以随便
	{
		for(i = 0; i < 8; i++)
			dfs(x + dir[i][0], y + dir[i][1], i, num, sum);
	}else
	{
		if(map[x][y] == '*') return; //如果为*表示无法消除
		else if(map[x][y] == 'D') //如果为D代表已经找到这条线上的所有点
		{
			sum += num;
			return;
		}else
			dfs(x + dir[d][0], y + dir[d][1], d, num + 1, sum); //如果是L就一直超这个方向搜索下去
	}
}
int solve()
{
	int max = 0, i, j, sum;
	for(i = 0; i < 8; i++)
		for(j = 0; j < 8; j++)
		{
			sum = 0;
			if(map[i][j] == '*')
			{
				dfs(i, j, 8, 0, sum);
				if(sum > max)
					max = sum;
			}
		}
	return max;
}
int main()
{
	int t, i, ans, c = 0;
	cin>>t;
	while(t--)
	{
		for(i = 0; i < 8; i++)
			cin>>map[i];
		ans = solve();
		printf("Case %d: %d\n",++c,ans); 
	}
	return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics